Before things get locked in fully I want to point how that there are still lots of inconsistencies in the naming. I’m demonstrably not a big fan of programmatic abbreviations/portmanteaus, but a lot of things don’t make sense.
fluid.bufcompose~ as an example.
startFrame as an attribute (actually
startframe, but that’s another discussion), but then expects
numFrames as another. Why isn’t it
num? Why isn’t it
I understand things like
destinationgain is a bit long, but the
num prefix (to me) never seems appropriate.
There was also some mention of this making sense in a SuperCollider context, but as a Max user, I don’t know that I should be concerned with SuperCollider contexts (I imagine there’s to ‘right to left’ order in SC, but I would expect stuff to act that way in Max either way).