Again, separation in the DAW world

It seems the project is timely:

I hope this inspire you :wink:

p

1 Like

That’s pretty cool.

I started playing with a bit of batch segmentation in Reaper the other day, but didn’t get super far with it. So looking forward to picking your Reaper guru brain on a workflow there. (nearly 400 files with a total of nearly 4k onsets in them, which I want to break into individual files (I did manage importing/segmenting/exporting in Reaper, but couldn’t seem to offset all the onset detection slices back around 1ms to make sure nothing gets cut off the beginning (which it was)))

what did you use for segementation? the built-in reaper stuff?

Yeah.
The ‘Dynamic Split’ thing. I tweaked the settings a bunch and found a good medium for slicing up the sounds I need. Then using the (super handy!) Batch file/item converter to export the files.

The problem I was running into is that the segmentation was more-or-less spot on, except that it would chop a few samples late in the file. So if I play a segment, I hear a tiny click at the end of the file (which belongs to the next slice).

I was looking for slicer offsets, or a way to select all the slices created and offset them (by something like 1ms, to be “safe”) but couldn’t find what I needed. And google/youtube just led me to quantize-related functions, as opposed to just a temporal/universal offset.

Everything is better with pictures.

So the settings I was using:

(this is bouncing object sounds, hence the long lockout)

Zoomed in to the first transient:

At one point I thought that it was a left vs right channel thing, but here’s another transient:

you see the ‘leading pad’ at the bottom? that is the ms you want before the detection :wink:

1 Like

I think you’ll like the super geeky interface of the amplitude slicer

Definitely helps a lot here.

I’ve found myself still opening up the files in Audacity afterwards and trimming them down more precisely, but this at least does the bulk of the file management and stuff.

I might still pick your brain in person to see if there’s an easier/faster way to navigate to the start of each slice and hand tune it directly in Reaper after doing the leading pad, but I should be able to process a bunch more of the files semi-manually this way.

(this is for part of the stuff I want to test in the plenary)

1 Like

I have cmd+shift+left & cmd+shift+right mapped to Item navigation: Select and move to previous [resp. next] item. Along with up and down being mapped to horizontal zoom by default, you can verilly skip through your slices and adjust the boundaries. You might want something also to skip to the right edge of the current item.

I think shift+up/down inflates / deflates the waveform view, which can help with very fine editing as well.

I also have cmd+shift+r mapped to make a region from the selected item, which speeds things up greatly when you want to bounce them all individually.

1 Like

Yup, I mapped those very things just a few days ago and have been working through the library now.

I think I cocked up the minimum length segments or something, because a good percentage of the slices are like 20ms+ from the transient, so I was having to zoom in and out for each segment. I’m now doing it in two passes, one crude, and one fine, so it saves me zooming all over the place.

It’s still super time consuming, but getting there…

But yeah, Reaper is really handy for this kind of shit it seems.

So after spending the better part of this week fine tuning the starts of all the loops (3094 individual items…) I’ve run into a massive problem.

Somewhere along the line, I don’t know how/where, but the Rate for all my items/slices got set to 0:442 (I noticed this when finally bouncing out the files and hearing they were all slow and fucked up sounding).

I wonder this has something to do with the sample rate of the files being 192k, but my audio driver is set to 44.1k? (the Reaper project settings are still 192k, but each item has a little “i” which says “Resampled from 192.0kHz”.

I’m 100% certain that I didn’t alter the Rate for all the items, and 98% certain that I did not press some silly hotkey and accidentally changed all the playback rates as I’ve been listening to bits of the files as I’ve been going and nothing has sounded silly. Plus the rate modification is the same, and on every single item.

So I tried to fix it.
No big deal, just select them all and F2 to change the playback rate to 1.0.

BUT

This keeps the current item length… which turns each item into an item that contains several hits because it is playing back almost twice as fast as before.

So if I select all the items and drag them back by the appropriate amount, it doesn’t work either because I’m shrinking the files by an absolute amount, whereas the 0.442 rate is a proportional modification.

I can solve the problem by ALT dragging the end of each clip until the rate goes back to one and the file length is correct, but I can’t impress on how little I can bear manually dragging item lengths again (I must have spent close to 8 hours doing this shit this week).

Is there some Reaper guru way of adjusting all the item lengths by a proportionate amount, or figuring out what is/has caused this?

Hmm, semi tragedy avoided?

Looks like my .bak file is fine, so maybe something got fucked up when I was trying to batch export and downsample there. Really weird and scary as that’s sooo many hours of work potentially lost.

I might export all the files at 192k, import then into another reaper project and then batch downsample them there as to not corrupt this project, or whatever it is that happened.

this is indeed a strange behaviour… Happy you found an happy ending ! you prompted me to check for relative duration changes - so it seems it is only for MIDI event! You would have had to script then, like I did in my free scripts. Not too hard if you like Python!

Bouncing it all now from a backup of the backup and it looks fine. So not sure what happened.

Almost gave me a heart attack!

You can at least stop that happening by unticking ‘loop source’ in the item properties 35

2 Likes