Bugs in max

hi, i got errors on a lot of objects, for instance:

fluid.bufstats~: “select” is not a valid attribute argument

fluid.bufmfcc~: No valid output has been set

fluid.bufampslice~: doesn’t understand “slowrampup”

fluid.bufspectralshape~: No valid output has been set

so i can use no of the examples from GitHub - tedmoore/FluCoMa-Pedagogical-Materials: FluCoMa Pedagogical Materials


latest max, monterey 12.6.8.

This is very strange… @tedmoore’s patches seems up to date and these are huge mistakes… did you install using the Package Manager?

yes, and reinstalled few times

which maxpat file are you in? that might help us narrow it down?

i cant attach as im a new user, its name


out of pedagogical materials

I just tested on my computer and it all worked as expected. Can you determine when exactly the error appears?

video :

at first i imitated the initialising (got same errors when open the patch)

1 Like

ok let’s start simple, because this looks like you have conflicting versions of the objects in your max path.

  1. in the package manager, uninstall FluCoMa.
  2. restart Max
  3. make a new patch, and instantiate one object [fluid.bufstats~]
    3a. if it works, it means you have the object somewhere outside of your package manager. this is a pain but we can try to help find where you would have installed it. You can also send a [version] message to it and that should be old.
    3b. if that does work (as it shouldn’t) reinstall the package manager version
  4. make a new patch, instantiate one object [fluid.bufstats~] and send a [version] message to it.
  5. report back what you have.
1 Like

everything worked :slight_smile:

i ve found outdated externals and removed them.
thank you for swift responses !