FluidCorpusMap.segmentFile ERROR

Hi All,

I am trying to run the example.scd in the https://github.com/flucoma/FluidCorpusMap repository.

When I run:
FluidCorpusMap.segmentFile(kernelSize: 11, threshold:0.025)

After selecting a .wav audiofile, I get this error:
Training AE and Segmenting
/usr/bin/python3 “/home/marcello/FluidCorpusMap/Extensions/FluidCorpusMap/segment_ae.py” “/home/marcello/Music/Samples/Bells/bell1.wav” “~/Documents/Flucoma/Index/” 11 10
Error in AE extraction
ERROR: ‘Routine-awake’ Out of context return of value: nil
Instance of Routine { (0x7fac5c157b98, gc=30, fmt=00, flg=00, set=05)
instance variables [27]
state : Integer 5
func : instance of Function (0x55927e66b9c8, size=2, set=2)
stack : instance of Array (0x559279d9d040, size=1, set=9)
method : instance of Method Meta_FluidCorpusMap:prSegmentExternal (0x55927b6e8780)
block : instance of FunctionDef in Method Meta_FluidCorpusMap:prSegmentExternal
frame : Frame (0x55927d7665d8) of Function
ip : RawPointer 0x55927b6e8f11
sp : RawPointer 0x559279d9d068
numpop : Integer 0
receiver : instance of Meta_FluidCorpusMap (0x55927b6df680, size=19, set=5)
numArgsPushed : Integer 1
parent : instance of Thread (0x559277172048, size=27, set=5)
terminalValue : nil
primitiveError : Integer 0
primitiveIndex : Integer 0
randData : instance of Int32Array (0x559277172278, size=4, set=2)
beats : Float 657.071071 8D8B8823 40848891
seconds : Float 1574.220238 86074091 409898E1
clock : instance of TempoClock (0x55927710ff38, size=7, set=3)
nextBeat : nil
endBeat : nil
endValue : nil
environment : instance of Environment (0x5592793192d8, size=5, set=3)
exceptionHandler : nil
threadPlayer : nil
executingPath : nil
oldExecutingPath : nil
arg this =
arg this = nil
arg error =
arg this =
arg error =
arg this =
arg this =
arg method = Routine:awake
arg result = nil
arg this =
arg inBeats = 657.071070757
arg inSeconds = 1574.22023784
arg inClock =
var temp = 657.071070757
^^ The preceding error dump is for ERROR: ‘Routine-awake’ Out of context return of value: nil
RECEIVER: a Routine

Am I doing something wrong or did I run into a bug?

this thread can be closed, a python library was missing, that’s why it was giving an error.

In case someone run into a similar problem, i suggest to run the python script in the command line with the same parameters given in the SC post window. In my case:
/usr/bin/python3 “/home/marcello/FluidCorpusMap/Extensions/FluidCorpusMap/segment_ae.py” “/home/marcello/Music/Samples/Bells/bell1.wav” “~/Documents/Flucoma/Index/” 11 10
That provided me with an understandable python error (missing library) that I could then fixed.

The thread can be closed.


This thread was useful to find a few updates needed, so no worries! We’ll push the updated version soon.