Getting start on a new Mac with Pd

Hi folks.
I’m finally getting around to playing with flucoma after watching from the sidelines since the early days. However I’m falling at the first hurdle!

I’ve got a new university-issued laptop, an M1 MacBook Pro, and I can’t get any of the flucoma patches to open in Pure Data 0.51-4 or 0.51-3. I’ve tried with the downloadable binaries, but every time I open a help file (or try to create an object) Pd will crash. I can’t get any crash logs or messages from anywhere to give me any clues, it just silently crashes, or sometimes silently hangs until I try to do something else with Pd, when it then crashes.

So I tried to be proactive and compile everything from source (setting the architecture flag as detailed here), and it gets 38% of the way through before printing a bunch of errors and failing. I’ll post some screenshots of the errors, if that’s helpful.

One other odd thing that’s been happening - I’ve had a very similar issue with a totally different set of objects, the DeepLearningWithAudio library. The behaviour is almost identical in terms of crashing, and I’m wondering if the problem is the same…I’ve detailed that issue on their GitHub and haven’t figured it out yet.

The final thing to say is that as a university issued laptop I believe I do not have complete control over it…I have admin privileges but I think there is a super-user level that I don’t have access to, so there’s possibly a chance that something is getting blocked from running? I would be surprised, especially considering the number of academics using this software, but I thought I should mention it.

The problem is M1… If uni-controlled, I wonder how you can compile yourself? if not I can DM you versions that are roseta2 compatible - we are very soon a beta03 release which has in Pd almost all of the dataset stuff (machine learning and all) but the helpfiles are nonexistent for that bit…

As @tremblap pointed out it’s an M1 thing. Because the version you’ve tried to use has AVX instructions enabled it crashes under Rosetta. This is a wart lots of people are dealing with which is why you felt like you had seen the issue around before :slight_smile:

We have a working build ATM. In fact it seems to run well on my M1 without a hitch in vanilla and 2lork. I’m more of the opinion we should just give it to you so you can start playing with the caveat that the documentation is a bit thin on the ground and if you’re willing to be a bit of a guinea pig. Does that sound good :)?


ha, I’m always happy to be a guinea pig! I would love to get any builds that should work on my machine.

@tremblap I should clarify that the laptop is uni-issued, but I do have admin rights so I can do most things. I only mention it because at my last university position I had a computer with admin rights but I didn’t have firmware-level access so there were a few things I was blocked from doing despite being an admin. I’m not sure yet if that’s the case with this laptop, I just thought I should mention it.

Here you go!

Let me know how it goes on your machine.

1 Like