Max objects missing?

I tried running this patch from the thread here:

After downloading the FluCoMa objects from:

I am still missing the following:

newobj: fluid.kdtree~: No such object
newobj: fluid.dataset~: No such object
newobj: fluid.normalize~: No such object
newobj: fluid.umap~: No such object

I don’t see these in the externals folder of the download. Where do I find these externals?

Hi @jthompson

Those objects are all compiled into a single binary so they can talk to each other easily (it’s called. fluid.libmanipulation.mxo in Max; we do the same in SC). You possibly will need to restart Max after installing so that the init file Max relies on to map object names to this file has been consumed and run.

If you’ve already done that and / or it still doesn’t work, we can kick its tyres a bit


User error. I placed the flucoma folder into the search path but not into the Packages folder … which is where it has to go.

Sorry for the noise.

1 Like

This happens a fair bit so youre not alone :stuck_out_tongue: is there anyway that we can make this clearer? It would be interesting to know where you grabbed the package from so we could plaster the advice directly there for example.

Well, it is right there in the “”, so why did I miss it?

I guess maybe a “” or even “” might have caught my attention a bit better? A readMe on the GitHub page might help.

Who knows what causes users (such as myself) to just start throwing stuff around without taking a moment to read what has been written (mea culpa).

I think eventually just getting this through the package manager is going to solve the problem.

You’re right, the package manager would solve all those issues. I think we could flag it on the front page of GitHub better as many people pass by there.

1 Like