Multiple error 1114 loading externals (Win10)

Hi, great project. Unfortunately, on my first try, nearly no external loads successfully. I’ve put the FCM folder into the Max 8 Packages folder.

Additionally, when I try to open the help patcher for the very first object (fluid.onsetslice~), Max crashes instantly.


This is strange, since we just ran a workshop with it with some participants being on windows machines… are you on a 64 bit machine? I don’t think Cycling supports 32 bit Win anymore but maybe they do and that would explain your problems… but also we compile with AVX so if your machine does not support that acceleration that might be the other issue.

The Cycling forum is short on details on their ‘Error 1114’ so a bit more on your setup would help us help you.

Thanks for the response.
Max: “Version 8.1.10 (f1acba9) (64-bit windows)”
OS : “Microsoft Windows 10 (build 19041), 64-bit”

I’m not sure about the AVX support. Normally, Intel Core i5 should have it but this one is from 2010 i think.
I’m now updating Max to 8.1.11 to be sure. If I find any more info, I will report back. Thanks,

That’s it! Not all i5 support AVX. 2 options for you:

  • you can compile yourself, we have tried to make the options super clear
  • you can wait until the next release where we are exploring ways of trying to support old architectures better.

I’m instantly thinking about option 3: buying a new computer :smiley:
Maybe I’m trying to compile myself eventhough I haven’t had the chance to check out the possibilities of the package. cheers,

1 Like

Hi, I managed to generate the build in the MINGW64 environment (not using VS). I entered -mcpu=native for FLUID_ARCH. Then I tried “make install”. First error that came up I solved by adding -D_USE_MATH_DEFINES to the compiler flags. But now I’m stuck when it hits the first external. A file / folder named wd4814 is required but I have no idea what it is.

The best place for this would probably be on GitHub, but @weefuzzy is the boss… I never compiled outside of VS so I wouldn’t know…

OK, no problem. I can’t wait to get my descriptors. Thanks for now

1 Like

Hi @11olsen,

Thanks for your perseverance. I’ve never tried with MinGW (it wasn’t clear if they were keeping up enough to support C++14), so you’re going to have a bumpy ride here I’m afraid (visual studio should Just Work, btw).

The error looks to me suspiciously like G++ is trying to find a directory named after a Visual Studio warning code. The most likely explanation is that in our CMake, I’ve disabled that warning and have done so detecting Windows in general and not Visual Studio in particular, and so is feeding g++ meaningless options. I’ll have a look.

Actually, I blame C74 f or this one (I inherited their mistake…)

In your flucoma-max source folder, try editing source/script/max-posttarget.cmake and commenting out line 99. You’ll need to re-run cmake after.

1 Like

Yes, thanks. Sorry I just opened an issue on github for what you just answered here. If the errors don’t stop i’ll give VS a try. cheers, O.