Upload size limit (and types)?

Whenever I try to attach (small) files to posts and I’m over a certain limit I get this popup:

The thing is, my file is nowhere near 8mb.

It’s a bummer, but it makes sense that there’s an upload size limit, but can the error message reflect what that file size limit actually is?

Also, given the nature of the forum, can the file types that are allowed to be uploaded take into account audio files?

I think this is default for Discourse, but for the type of things that get posted here, .wav, .aif, .mp3 (even .sf2!) would all be welcome additions.

8192 kb is the max indeed. Let me know the actual size of what you try to upload and I’ll check with the discourse people.

We won’t host audio, for obvious hosting spiralling cost reasons. It is a bit sad for posterity, but not that much.

The file I tried to upload was 1.3mb. I seem to get that error whenever something is over 1mb, but I’ve never sat down at tested the limits to see where it actually cuts off.

With the file size limit, the file types shouldn’t matter no? I’ve uploaded a handful of short audio files (rather than letting them evaporate off wetransfer), when they were small enough. Just always had to do it as a zip. Would be better if it didn’t need to be zipped is all.

I can attest I have had the same issue with file sizes not being right

this is biz. Let me try to upload something here

that was 1 meg, let’s try something bigger - oh you’re right it bails at 2.7 meg zip. Let me see…

Go for it, try it now in a relevant post! It should work!

I tried to upload an exactly 8mb file and it says it can’t upload more than 4096kb :slight_smile:

argh! was it an image? if yes I found another setting, but now that should be ok

It was! I’ll try again.

I just tried again, and I’m getting the same 8192kb error message when trying to upload a file smaller than that.

It looks like the cutoff for .zip files is 1mb (or rather, I wasn’t able to upload something that’s 1.2mb, but was able to upload two files that were around 500kb / 600kb).

Having a 4mb cutoff would be great, but if not, if the error message could say 1mb that would be much better, if it is to remain what it is.

it might have reverted back to the other value… I have to find a permanent fix for that but changing it implies recompiling the discourse container on the server so not trivial at all and downtime for everyone.

let me schedule that for tomorrow morning

1 Like

ok everything is 8192 max now. Can you try a dummy upload please? If not working, I don’t know what else I can do since I did everything requested here

Nope. 6.3mb file failed upload (same same 8192 error).

I also tried 1.6mb and 1.1mb (all zip files) and everything throws the same error.

Don’t know if this is relevant to a discourse thing, but for wordpress there’s a separate php/server setting that caps file size, essentially for the underlying database.

ok I declare the upload at 1m for now until we have a few days to lose, since even Discourse’s resource don’t agree. I’ve asked our lovely system admin as a last attempt.

1 Like

Yeah, that will at least be consistent and not so confusing when uploading files.

I’ve tried and get this for a 2meg zip. I’ll fight a bit

1 Like

That’s promising. Particularly for audio examples, the diff between 1mb and 2mb is huge! Thanks for faffing around with it.