Asinglewordisnotenough3 - the patch

Hello

As promised, albeit a bit later, the patch, the score, the notes and the album version of the piece I presented. You have there in the patch folder:

  • the calibration routine
  • a descriptor based granulator
  • my favourite compander
  • my favourite live reverb

I hope you enjoy some of it.

p

Did you mean to link some files?

no I just meant to be cryptic :wink:

https://huddersfield.box.com/s/8tqoe9uscdt5zo0r7vjyhs50glcp1tc2

(as a point of reference, for making the patch usable everywhere, something about the name of the master patch triggers Apples security thing):

This doesn’t happen with other .maxpat's so it’s not the extension.

I tried removing the “-Perf-Patch” bit, as well as the “–” but it wasn’t happy either way.

You can still select ‘open’ from within Max, but you can’t drag the file onto the Max icon. But it may crop up as a problem on a foreign computer or a non(OS)-techy person.

(this is from OSX Sierra, and presumably above where you cannot disable this behavior by default)

I get that with all my patches starting with - but this is a way to keep the right patch at the top. Feel free to change the name in your download. Usually I load from the load folder anyway, in order to chose which Max (5-6-7) I use for which patch :wink:

In that case, _ does the same thing (what I use), and doesn’t suffer from this.

Hi PA,

Practical question on your performances. You specify that the SR should be 44.1 kHz.
Did you have situations, where the entire concert system would run on 48 (which is pretty common now) and your patch at 44.1?
Does Max a good job in resampling on the fly?

Best, Hans

Without knowing in detail, I do know that PA likes his index~ objects, which would be presumably set to count at 44.1k-specific rates, so 48k-ing the performance could potentially mess with pitch/tempo of samples and processes.

Have you tried downloading another maxpat from the internet to see if it triggers gatekeeper? It isn’t just the extension, it is also the source of the file.

It downloaded as a zip and other maxpats open up just fine so it’s something with that file (probably the - as @tremblap pointed out).

I never had any issues as I never run at anything else than 44.1kHz - I usually go analogue for most gigs anyway, direct mic (no desk) so just outs to the desk. When I run the gigs, I run them at 44.1 - never any issues from other composers