Beta00 is here!

Here we go! There are a few caveats, mostly for PureData users, and a few known bugs for all in contexts specific enough to not stop the first beta release to all our newcomers!

Here is the log, I hope you enjoy!


beta-00: the big plunge

date: 8 July 2019

New Features:

  • overview in SuperCollider, PureData and CLI
  • Max help overall review (uneven in completion)
  • support for 3 OSs (Mac, Windows, Linux) and 4 CCEs (Max, PureData, SuperCollider, CLI)

Known Bugs:

  • HPSS still cracks when percussive filter is violently moved up
  • NMF still creates NaNs in some edge cases, for instance when trying to factorise digital silence
  • BufOnsetSlice with a maxFFTSize value of less than 1024 will crash
  • BufNoveltySlice might generate garbage strange values in the first frame
  • AmpSlice is noisy when some parameters are changed
  • (Pd) help files are not finished yet!
  • (Pd) not providing enough ‘channels’ in ‘multichannel’ arrays will crash

In the download folder for Mac I only see

Where do we find the Max MSP version?

Thanks, Hans

uploading now - I found a few bugs so I corrected. Sorry!

(is there something going on with the thing? it’s going really slowly and both attempts to download it have timed out unrecoverably).

Some days it is very slow indeed… if it is bad tomorrow I’ll put an image on my so people can pick it up faster.

4th time it’s failed so far…

if you’re paying for the hosting you should give them some shit!

I’m not paying, the uni is providing. Let me upload them elsewhere.

I was able to download and install for SC 3.10.2 on Mac - excited to dig in.

1 Like

ok another link here in case you have issues with

1 Like

Will check this out tomorrow. I should have my laptop back and CLI away!

1 Like

Oh man, those help files!

Also, are truepeak and kweighting working?
And is fluid.ampslice~ working correctly now?

all of it yes. The last one - it always worked fine :wink: but it will need more tutorials. There is a behaviour I’m still not certain it is optimal.

1 Like

Thank you for this upgrade ! It seem to work all fine on my side.
More soon !!!


Hi all, 1st post, good to be here.

This is for Pd Linux:
I can’t get any of the classes to instantiate?

1 Like

really? Are you on 64 bit linux? if yes, I have very little facilities to test but @groma tried them with success… let’s put this post in the bug section and try to sort you out!

1 Like

So, good for old-timers to update? Doesn’t look like too much has changed, right?

1 Like

only bug reports… and a series of amazing new help files by @weefuzzy :wink:

1 Like

All looks/sounds good with linux cli so far.


Which distro are you running? Python + subprocess sucks compared to UNIX so I want to virtualise something to do batch processing away from my laptop.

Using Debian - not quite sure I follow- do you mean you’d prefer to stick to shell scripts over Python / thinking of some other approach for the mutithreaded processing?