Pd on Linux - objects not instantiating?

It seems we cannot instantiate. I don’t have a Linux machine. I’m happy to make a USB boot drive for my Mac (MacBookPro13,3) if anyone has a recommendation how to do it painlessly :wink:

@Julian ?

Cheers PA,

Yeah , not sure what’s going on here.

I’ve tried adding the folder to my prefs, various incantations of [declare] and also the old [folder_name/NameOfClass] trick too.

Not sure what I’m missing?

This is on Debian Sid/9.



What I do to get them to work is to declare the path of the folder with the externals in it. I do it in the ‘path’ preference but it also works with [declare -path]. It does NOT work if I declare the top folder, it needs to be the folder with the actual externals in.

Ok. I’ve just double checked, my setup is the same as your suggestion (I’ve renamed the folder, as ‘pd_externals’ isn’t helpful – I’ve mentioned this in my 1st notes:).

I’m out of time for today but will have another go later/tomorrow

Just to confirm, this line [declare -path /Users/pa/Desktop/flucoma-pd/pd_objects] makes me able to instantiate them in that patch. But I’m on Mac. So if that does not work on Pd we could try to recompile.

Ah ok - yeah, you shouldn’t have to declare the full path if the classes are in the main ‘Pd-Externals’ folder (with all the other externals).

Le me try that now…

1 sec

the suspense is unbearable…

Sorry :slight_smile: nope - tried another couple of options
Just ‘…couldn’t create’ errors all the way down

1 Like

hmmmm thanks for trying so hard. You did not have any problem at decompression of the zip? It might be corrupted… the google ones should be fine.

No errors reported, I’ll try the other option

1 Like

ok after trying to install Linux for the last 90 minutes, I will repeat what I always say: it is free if you do not count your time! It is still not working despite having it to almost work on a large drive but not being able to install it elsewhere… so I’ll wait for @groma and/or @weefuzzy to come back from holidays and we’ll run Linux on their Parallels and try to get Pd to behave. Stay tuned!

1 Like

LOL - yes, I have heard you say that before.
(Maybe if apple hadn’t forked and put linux essentially under proprietary lockdown none of this… (yeah yeah, you’ve heard me say this too:)

Anyhow, both versions of dl are the same.

If there’s a simple’ish script/makefile I’d be happy to build from source?

And yeah, any other Pd folks want to weigh in, please give us a shout.

1 Like

summarily the pd_linux files should be “fluid*” not “libfluid*”, renaming them works. The debug output showed pd couldn’t find the symbol “setup_libfluid0x2esines_tilde”, nm output showed the symbol was actually “setup_fluid0x2esines_tilde”

run this in the dir containing the *.pd_linux files to rename them appropriately and they instantiate (not tested functionality yet though)

for x in libfluid*.pd_linux ; do mv $x `echo $x | sed  "s/libfluid/fluid/g"`; done

kind of a really dull fix for something that looked potentially exciting…


Many thanks @richardK for tracking this down.
Classes now instantiate (with non-fatal error, eg,
"fluid.bufonsetslice~_warnings: only 5 arguments are typecheckable; use A_GIMME " ).

From a very quick check, currently all objects are Crashers when audio activated - will investigate further later.

One step forwards … :smiley:

thanks Richard, I’ll put up a bug report and we’ll correct for beta01 - I think @a.harker will know where to fix that in the cmake I reckon…

1 Like

The ‘helpfiles’ are more ‘testfiles’ at the moment, you can try them and let me know?

BTW, I’m translating the Max ones with readable text in the next few days (about 30h of work, mostly boring - I think of making a temp folder on the server so you guys can pinch them as I update them. Good idea?

Yes, definitely.

It’s the helpfiles I’ve tried that are crashers(segfaults). Will explore some of the classes themselves and see what happens - will let you know later tonight…

Segfault happening here as well…
gdb on sines says

0x00007ffff16442d2 in hisstools_fft_impl::SizedVector<4, hisstools_fft_impl::AVX256Double>::SizedVector(double const*) ()

similar issue with all of the objects I tried.
Running: Debian 9.6 , glibc 2.24-11+deb9u3, pd 0.47.1

@richardK - what is your hardware? Does it support AVX?